Netgear R7000 DD-WRT Not saving config

9 posts / 0 new
Last post
jarapablo
jarapablo's picture
Netgear R7000 DD-WRT Not saving config

Hi Guys, I have tried a few custom firmwares on my Netgear r7000 and they all have their pros and cons. I tested successfully Merlin and Tomato but wanted to give dd-WRT a try as it's very popular. 

I installed the latest versions I found on Kong and Brainslayer's repositories but it seems to be a bug. I have tried several browsers and different versions but each time I reboot my router the config resets to its default. Am I missing something? I hope you can help. 
 
Currently I am on v3.0-r35030M
michelb
michelb's picture
I have the same problem too ?

I have the same problem too ???

darkmage1991
darkmage1991's picture
Happening with me too. Just

Happening with me too. Just searched the net for an old build though (29300) as I once used it without issue. But so far I have tried latest beta and latest stable and both just refuse to retain settings and want to reset the admin password every boot along with all other settings. I'll report back after I try 29300 build.

darkmage1991
darkmage1991's picture
Ok I have absolutely no idea

Ok I have absolutely no idea what's wrong. I tried the 29300 build and still it won't retain any settings. I tried redownloading the initial firmware thinking it was the issue but alas it isn't. So idk...tomato and stock work fine.

If anyone happens to know the issue would love to know.

darkmage1991
darkmage1991's picture
Sorry for multiple posts

Sorry for multiple posts having to use my phone to make posts as my internet is down while messing with this.

I have giving up though. I have tried going back to stock wiping nvram each flash and tried again to ddwrt tried multiple firmwares and tried waiting 20+ minutes before trying to change any settings. It just won't retain any settings no matter what. I've tried the builds on ftp://ftp.dd-wrt.com/betas/ and http://www.desipro.de/ddwrt/K3-AC-Arm/ all with no luck.

I tried to use my laptop to flash the firmwares incase it was my PC with no luck. I just don't know.

I wanted to use ddwrt to set it up as a client as tomato just doesn't work as good for that but damn... Ddwrt is just broken.

blackrider
blackrider's picture
I'm definitely in the same

I'm definitely in the same both. I have tried all the varying builds and experiencing same result. It practically reset itself as soon as one reboots it any way, be it from the gui interface, command line or unplugging the powercord. Assistance needed from the better informed.

blackrider
blackrider's picture
In the same boat I meant. lol

In the same boat I meant. lol

xotter
xotter's picture
I have same problem.   I also

I have same problem.   I also tried a version of dd-wrt which worked previously but now it won't save configuration changes.  I have also tried several variants of resetting and other firmware as others with the smae results.  Any suggestions are welcome.

djk44883
djk44883's picture
Still no credable suggestions

Still no credable suggestions? as I have found this issue as well.  I had been running dd-wrt since I hada 54g.  Currently have a netgear r7000, changed from dd-wrt to xwrt, decided it wasn't what I wanted.  Had to "back to stock" to flash to anything else.  Flashed newest fresh tomato firmware.  Works and look great, except my rounter nolonger has AC capabilities.  Tried resetting to factory and flashing to dd-wrt.  Change password at initial screen, choose to factory reset and reboot again... reset usernam and password (as expected)  I don't recall wireless security being setup in the past - either things changed or I didn't clear/reset things.  Change some settings, reboot routher and again asked to set username and password - not expected.

Multiple times I set user/pass, reboot - repeat.  This is the same version 9-23-2019 dd-wrt I was using before I switched to other firmware... so it has worked with this router.  Other than install fresh tomato has anyone discovered what's up with this?

I had similar issues with other forum topics, default passwords not working ( and to power cycle).  Need to revert with inital flash to allow any upgrade (not from factory) And I'm not entirely certain I've complety cleared settings. I've held a wps button while powering on.