Netgear R7000 hangs hours after disabling wifi via SSH

2 posts / 0 new
Last post
genlish's picture
Netgear R7000 hangs hours after disabling wifi via SSH

Hi everybody,
Router: Netgear R7000

DD-WRT v3.0-r31870M kongac (04/16/17)
I've made an script (tried different versions) to disable wifi interface (2,4GHz) executed via SSH:
method 1:
stopservice nas

sleep 10

/usr/sbin/wl -i eth1 radio off

sleep 5

startservice nas
method 2:
#! /bin/bash

/usr/sbin/wl -i eth1 radio off
method 3:
startservice radio_off_0

sleep 5

stopservice radio_off_0
method 4:

ifconfig eth1 down
All of them makes the purpose, wifi disabled OK, but the problem comes after a few hours of executing the script, the router hangs and looses conectivity, it seems like DHCP stops working, because it doesn't serves an IP, but in fact, I don't know what is happening, but I have to restart the router everytime it happens.
Same problem if I try to disable the eth2(5GHz) instead of eth1, and same problem if I try to disable both at the same time.


The way for disabling the wifi should be by script because I want to schedule on a cron task at different times, weekdays and weekends, impossible to do 

through Radio Scheduling on the GUI.

Cron task are like:

0 23 * * 1,2,3,4 root sh /jffs/cron/

any suggestion?

Thanks in advance.

Aleks's picture
I have exactly the same issue on my R7000 on DD-WRT v3.0-r35030M.
I use cron table for scheduling to switch off the wifi during the night and reenable it on morning.
In morning, the router seems to be crashed.
I tried to activate the syslog on a permanent destination but nothing appears on it.
Did you find the cause ?