New Build from Tathagata Available

9 posts / 0 new
Last post
Peter Redmer
Peter Redmer's picture
New Build from Tathagata Available

FYI - there's a new build from Tathagata available:

Has anyone tried this out yet?

gennadiv's picture
Hi Peter,

Hi Peter,

Yes, I did on R8000

3 things found so far:

1. WAN issue yet to be fixed - when I rebooting router, I'm getting no WAN IP, but zeros. So using startup script as a workaround

2. For some reason, same place I've got a decent reception at home (front porch) on Kong build - cannot even get connected neither with Macbook nor with android to both 5.8Ghz radios. However, 2.4Ghz works excellent... That is strange

3. Router hung yesterday evening for no reason and had to restart... - need more time to check it out

Hope Tathagata will invest some time to fix those issues

Is there any other build apart of Tathagata or Kong ( from march) on the market?



tal69's picture
Steer clear of this build on

Steer clear of this build on Netgear R8000.


There are many radio inconsistencies.  For the most part it is impossible to get both 5Ghz radios working.  


Most of the other functionality seems to work including VLAN's on LAN Ports and such.  Unfortunately for me I need the radio coverage as an AP...

Paint's picture
I am trying to compile DD-WRT

I am trying to compile DD-WRT for my Netgear R8000, but I am having some issues compiling Zabbix. 

Can someone please provide any clues to whats failing? 

I have installed all of the requirements and libraries (or at least I think I do). 

OS: openSUSE 13.2 x64 
SVN: 27480 
Router: Netgear R8000 
Toolchain (6/22/15): toolchain-arm_cortex-a9_gcc-4.8-linaro_musl-1.1.5_eabi 
Config: .config_northstar 

Here is a link to the complete console log while I attempt to compile DD-WRT.

In addition, Tathagata would you be able to share your DD-WRT SRC folder? I would love to be able to help you with fixes for the R8000 since there is no love for this router on the DD-WRT forums. Thanks!

Mojolacerator2's picture
I agree - with Tal69 - flash

I agree - with Tal69 - flash with caution.


I flashed my R8000, everything worked super fast, MY accesspoints, hardwired "stuff". But when I connected to any wireless radio on my R8000, I could not access the internet. I could with my access points, no problem, and speed was super fast. Must be some radio issues still.

Paint's picture
This version works great for

This version works great for me. If you upgrade to this version, please delete your NVRAM settings correctly. It is important that you do this so that old, bad NVRAM settings from past R8000 builds are cleared and reset. 

The only issue I have is that one of the AC networks, WL0, only works at sub-AC based speeds. WL2 works at 866mpbs.

By deleting my NVRAM settings correctly, my MAC address for my WAN is the correct MAC (not 00:00:00:00:00:02)

Please follow these instructions I posted on the How-To forum:

Mojolacerator2's picture
Flashed the software properly

Flashed the software properly cleared nrvram, etc., issue persists.

Kong's build seems more stable in my environment, no issue with AC speeds.

zhopa's picture
Works great with R6400. Way

Works great with R6400. Way better and faster than the stock firmware. Thank you!

volodymyr's picture
Hi Tathagata!

Hi Tathagata!

First of all, thanks for your DD-WRT builds for Netgear devices! They worked great for me and I became really interested in creating my own build for experimenting with my devices.


Right now I'm experiencing an issue with the boot (wl.ko loads and causes a kernel panic). I'm trying to figure out the reason, but looks like I got stuck :(

Can you please share your .config file so I could compare contents with one I use? Should be there any modifications to the build process except for the obvious stuff described on the DD-WRT forum?

Thanks a lot again and I really looking forward to feedback :)


Just in case, here is the fragment of my stacktrace:


nat_rtsp v0.7 loading
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 17
bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
Bridge firewalling registered
8021q: 802.1Q VLAN Support v1.8
Registering SWP/SWPB emulation handler
max nvram space = 131072
read 131072 bytes to offset 0
Key type encrypted registered
Northstar brcmnand NAND Flash Controller driver, Version 0.1 (c) Broadcom Inc. 2012
nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xf1
nand: Macronix NAND 128MiB 3,3V 8-bit
nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
Spare area=64 eccbytes 56, ecc bytes located at:
 2 3 4 5 6 7 8 9 10 11 12 13 14 15 18 19 20 21 22 23 24 25 26 27 28 29 30 31 34 35 36 37 38 39 40 41 42 43 44 45 46 47 50 51 52 53 54 55 56 57 58 59 60 61 62 63
Available 7 bytes at (off,len):
(1,1) (16,2) (32,2) (48,2) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) 
Scanning device for bad blocks
Creating 1 MTD partitions on "brcmnand":
0x000002000000-0x000007000000 : "ddwrt"
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 340K (8044d000 - 804a2000)
start service
starting Architecture code for northstar
cannot open /dev/nvram
udevtrigger[362]: parse_config_file: can't open '/etc/udev/udev.conf' as config file: No such file or directory
1970-01-01 00:00:05 main: Sanity checks succeeded
length = 0
try modules for ethernet adapters
et: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0x400
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
ET Corerev 7
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r524987)
et2: etc_attach() failed
roboswitch: Probing device 'eth0'
roboswitch: trying a 53011! at eth0
detected CPU Port is 5
roboswitch: found a 53011! at eth0
detected CPU Port is 5
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
PCI: Enabling device 0001:01:00.0 (0140 -> 0142)
Unable to handle kernel NULL pointer dereference at virtual address 00000000
pgd = 879a0000
[00000000] *pgd=0717e831, *pte=00000000, *ppte=00000000
Internal error: Oops - BUG: 817 [#1] SMP ARM
Modules linked in: wl(P+) igs(P) emf(P) switch_robo switch_core et(P)
CPU: 0 PID: 601 Comm: insmod Tainted: P                4.4.62 #2
Hardware name: Northstar Prototype
task: 87aa0000 ti: 871b4000 task.ti: 871b4000
PC is at memcpy+0xb4/0x330
LR is at 0xf4c9000
pc : [<80011e54>]    lr : [<0f4c9000>]    psr: 00000013
sp : 871b5c44  ip : 0000001c  fp : 871b5cd4
r10: 864b73c0  r9 : 00000000  r8 : 00000000
r7 : 872d0000  r6 : 7f422840  r5 : 87b58000  r4 : 8708d400
r3 : 87acb000  r2 : ffffffe6  r1 : 8708da08  r0 : 00000000
Flags: nzcv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5387d  Table: 079a004a  DAC: 00000055
Process insmod (pid: 601, stack limit = 0x871b4190)
Stack: (0x871b5c44 to 0x871b6000)
5c40:          87b58000 7f422840 872d0000 00000000 00000000 8708d400 7f18f290
5c60: 00000000 864b73c0 89df8000 00000001 87b58000 00000000 871b5ca0 871204e8
5c80: 87120588 000000a3 000014e4 00004331 08000000 87acb000 871b5ccc 06035801
5ca0: 00000000 871b5cb0 80195484 7f421ab0 87b58000 87b58068 7f421ae4 00000000
5cc0: 7f421ae4 00000028 871b5cfc 871b5cd8 80171b68 7f18eebc 87b58068 8052996c
5ce0: 7f421ae4 80529960 00000002 7f421ae4 871b5d24 871b5d00 80198fb4 80171b04
5d00: 87b58068 87b5809c 7f421ae4 804c3188 00000000 871b5f3c 871b5d44 871b5d28
5d20: 801990d4 80198e68 00000000 7f421ae4 80199080 804c3188 871b5d6c 871b5d48
5d40: 801977d4 8019908c 878abd5c 87b1a534 80147198 7f421ae4 87a94580 00000000
5d60: 871b5d7c 871b5d70 80198b0c 80197758 871b5da4 871b5d80 801987bc 80198af8
5d80: 7f38d534 871b5d90 7f421ae4 872a0980 804b9918 804b9918 871b5dbc 871b5da8
5da0: 80199768 80198650 7f422840 872a0980 871b5dcc 871b5dc0 80171418 801996dc
5dc0: 871b5de4 871b5dd0 7f4450cc 801713e4 7f445000 872a0980 871b5e5c 871b5de8
5de0: 80017c3c 7f44500c 864b74e4 871b5f3c 00000002 872a0980 00000001 00000001
5e00: 864b74e4 871b5f3c 871b5e34 871b5e18 800afe1c 800b7098 00000494 87275c00
5e20: 00000001 00000001 00000494 87275c00 00000001 00000001 864b74e4 7f421f80
5e40: 00000001 87275c00 00000001 864b74e4 871b5e84 871b5e60 80086b88 80017bdc
5e60: 871b5e84 871b5e70 800aff00 7f421f80 00000001 864b74c0 871b5f34 871b5e88
5e80: 80088210 80086b34 7f421f8c 00007fff 7f421f80 80086154 0008f180 7f4220d8
5ea0: 80010014 89deed30 00001664 803eed3c 00001664 7f421fc8 80009e80 8000931c
5ec0: 89d481c0 76df31e0 00002dc0 00000000 00000000 00000000 00000000 00000000
5ee0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
5f00: 00000000 00000000 80088694 00003d80 76e99d90 00000000 0008f180 89deed80
5f20: 871b4000 00000000 871b5fa4 871b5f38 80088744 80086d5c 871b5fb0 8995b000
5f40: 00493d80 89dee880 89d55631 89d6bd94 003f993c 004074dc 00000000 00000000
5f60: 00000000 00032984 0000001e 0000001f 00000017 00000000 00000012 00000000
5f80: 00000000 76f33fd0 00000000 00000080 800096e4 871b4000 00000000 871b5fa8
5fa0: 80009540 80088640 00000000 76f33fd0 76a06010 00493d80 0008f180 76f33fe0
5fc0: 00000000 76f33fd0 00000000 00000080 7efc1ec4 000768ec 000752e7 76f33fd0
5fe0: 7efc1c4c 7efc1c30 0001e4e4 76eedfb0 20000010 76a06010 00000000 00000000
[<7f18eeb0>] (wl_pci_probe [wl]) from [<80171b68>] (pci_device_probe+0x70/0xb8)
 r10:00000028 r9:7f421ae4 r8:00000000 r7:7f421ae4 r6:87b58068 r5:87b58000
[<80171af8>] (pci_device_probe) from [<80198fb4>] (driver_probe_device+0x158/0x224)
 r9:7f421ae4 r8:00000002 r7:80529960 r6:7f421ae4 r5:8052996c r4:87b58068
[<80198e5c>] (driver_probe_device) from [<801990d4>] (__driver_attach+0x54/0x94)
 r9:871b5f3c r8:00000000 r7:804c3188 r6:7f421ae4 r5:87b5809c r4:87b58068
[<80199080>] (__driver_attach) from [<801977d4>] (bus_for_each_dev+0x88/0x98)
 r7:804c3188 r6:80199080 r5:7f421ae4 r4:00000000
[<8019774c>] (bus_for_each_dev) from [<80198b0c>] (driver_attach+0x20/0x28)
 r6:00000000 r5:87a94580 r4:7f421ae4
[<80198aec>] (driver_attach) from [<801987bc>] (bus_add_driver+0x178/0x1e8)
[<80198644>] (bus_add_driver) from [<80199768>] (driver_register+0x98/0xd8)
 r7:804b9918 r6:804b9918 r5:872a0980 r4:7f421ae4
[<801996d0>] (driver_register) from [<80171418>] (__pci_register_driver+0x40/0x48)
 r5:872a0980 r4:7f422840
[<801713d8>] (__pci_register_driver) from [<7f4450cc>] (init_module+0xcc/0xd8 [wl])
[<7f445000>] (init_module [wl]) from [<80017c3c>] (do_one_initcall+0x6c/0x1a0)
 r5:872a0980 r4:7f445000
[<80017bd0>] (do_one_initcall) from [<80086b88>] (do_init_module+0x60/0x1a4)
 r8:864b74e4 r7:00000001 r6:87275c00 r5:00000001 r4:7f421f80
[<80086b28>] (do_init_module) from [<80088210>] (load_module+0x14c0/0x18e4)
 r6:864b74c0 r5:00000001 r4:7f421f80
[<80086d50>] (load_module) from [<80088744>] (SyS_init_module+0x110/0x11c)
 r10:00000000 r9:871b4000 r8:89deed80 r7:0008f180 r6:00000000 r5:76e99d90
[<80088634>] (SyS_init_module) from [<80009540>] (ret_fast_syscall+0x0/0x34)
 r9:871b4000 r8:800096e4 r7:00000080 r6:00000000 r5:76f33fd0 r4:00000000
Code: e4805004 e4806004 e4807004 e4808004 (e480e004) 
---[ end trace 796d45465dcbb56c ]---
Kernel panic - not syncing: Fatal exception
CPU1: stopping
CPU: 1 PID: 0 Comm: swapper/1 Tainted: P      D         4.4.62 #2
Hardware name: Northstar Prototype
[<8001aad0>] (dump_backtrace) from [<8001ac94>] (show_stack+0x18/0x1c)
 r7:87853f60 r6:60000193 r5:00000000 r4:804c2c9c
[<8001ac7c>] (show_stack) from [<80144df8>] (dump_stack+0x84/0xa0)
[<80144d74>] (dump_stack) from [<8001c678>] (handle_IPI+0x104/0x19c)
 r7:87853f60 r6:00000000 r5:00000001 r4:804d51a0
[<8001c574>] (handle_IPI) from [<80009384>] (gic_handle_irq+0x74/0x7c)
 r7:b0101100 r6:87853f60 r5:804b1b18 r4:b0100100
[<80009310>] (gic_handle_irq) from [<80009e80>] (__irq_svc+0x40/0x54)
Exception stack(0x87853f60 to 0x87853fa8)
3f60: 00000000 00008fea 86ddf254 8000a9a0 8049d224 804b18e0 10c0387d 804d5180
3f80: 0000406a 413fc090 00000000 87853fbc 87853fc0 87853fb0 800188fc 800188ec
3fa0: 60000013 ffffffff
 r7:87853f94 r6:ffffffff r5:60000013 r4:800188ec
[<800188c8>] (arch_cpu_idle) from [<80062da8>] (default_idle_call+0x30/0x34)
[<80062d78>] (default_idle_call) from [<80062ee4>] (cpu_startup_entry+0x138/0x15c)
[<80062dac>] (cpu_startup_entry) from [<8001c37c>] (secondary_start_kernel+0x10c/0x128)
[<8001c270>] (secondary_start_kernel) from [<00009428>] (0x9428)
 r5:00000055 r4:0782c06a