New Kong Mod Release - r18010 [Regular & King]

85 posts / 0 new
Last post
Kong's picture
zoomlink said: Ok guys... I

zoomlink said: Ok guys... I was a little concerned with the 'nf_conntrack: table full, dropping packet.' messages on my dmesg file. After a little searching I found this post which seems to explain an issue with iptables.,droppingpacket @Kong: Is there anything we can put in the system to avoid the what is explained in the the link above?

Just lower the TCP Timeout setting under Administration->Management

Kong's picture
Axel said: @kong. I am

Axel said: @kong. I am running 17670:17737M on an Asus RT-N16. There's a weird NAT issue in the following double NAT configuration. Perform factory reset using the webui. Set WAN adapter to DHCP. It receives and address on the network. LAN adapter is on the network. LAN DHCP server enabled. Internet gateway is (Linksys WRT310n DD-WRT connected to a cablemodem). My laptop is behind the Asus router. I get DHCP address fine. I can ping the Asus router. I can nslookup fine. I cannot ping any address on the network or on the internet ( times out). Web surfing does not work either. If I telnet into the Asus router, everything works as expected from inside the router. Now here's the really weird part. If I change the LAN segment from to and set the Asus router address to, my laptop's internet access is restored. Why on earth would the NAT fail if I used two class A subnets and work if I use a class A and a class C? I am about to put 100 routers in production using this firmware but this NAT issue is a showstopper for me. I would also like to know if I should use 17670:17737M or your latest 18000+ revision? I am not using the wifi adapter for this application, just using the routers as internet gateways and OpenVPN gateways. In the future I might want to use 3G on USB for WAN backup and optware on a thumbdrive for several other uses. Thanks in advance.

Hi Axel,

I'm pretty sure this is also an issue in the official builds, so please test with the latest official build and if it exists there too ask in the forum and maybe report it to dd-wrt trac, as I don't have the resources to checkout and fix all bugs.

zoomlink's picture


I was unable to reach my new router-child today. Let me axplain my situation.

1. I can reach the router via remote admin SSH.
2. I am UNABLE to reach the router's remote admin WEB interface from the WAN side.
3. It is properly configured for remote admin access via SSH and WEB but it seems like the web stopped working.
4. I can create a PPTP tunnel to the router, get a local IP but I am still unable to reach the WEB Interface, even from a local IP address. The funny thing is that I have vlighttpd running and I can reach the secondary and physical web addresses I setup just fine, yet the main WEB interface refuses to show up.

Now... from my SSH terminal session:

I do htop, and I can see 3 reboot attempts showing up as '/sbin/reboot' among other commands I have tried that seem to be hanging there doing nothing.

I tried 'init 6' when reboot would not work, and NOT EVEN 'init 6' worked!.

Unfortunately, I don't have anyone with physical access to the unit to have them pull the power plug, wait 2 minutes and plug it back in.

I have tried 'kill process#' and no joy either.


If you know of some magic command or set of commands I could give this now rouge-and-unwilling-to-reboot router, I would greatly appreciate it.

By the way, I also tried the sync;reboot and sync, then reboot. nothing.

It looks to me like memory problems but I just don't know what to think anymore... I am like a dog with a bone but the bone will not surrender.. :)

My OCD is driving me nuts!!! :)

zoomlink's picture
@Kong... need a little help

@Kong... need a little help please.

When you say that the current build does not support drives bigger than 2GB do you mean....?

1. That ANY drive that is physically bigger than 2GB will not work REGARDLESS of how it is partitioned?


2. That as long as I partition a 2.5GB drive in a way that makes the sum of all the partitions

This will leave 500GB of unallocated space on the drive but that is ok with me. If I can get this frigging drive to be recognized without the kernel throwing up the following error:

attempt to access beyond end of device
sda: rw=0, want=801344024, limit=588808192

Update: I am not the only one asking for this, see:

jujumug's picture
I recently switched my ISP

I recently switched my ISP and the new one offers internet WAN speed of up to 300Mbps through optical fibre. Plugging my laptop directly into the modem from my ISP, I was able to get about 270Mbps of download and about 200Mbps of upload speed. Going through my RT-N16 with KongMod r18010 installed, I was only able to get 65Mbps on both directions based on the same speed test and the system load was never above 0.5.

Does anyone know if I have reached the limit of DD-WRT or is it just a configuration problem?

I connect to my ISP through DHCP and have tested it with QoS turned off.


drakko's picture
Is there any chance for

Is there any chance for support Netgear WNR3500Lv2? Because at this moment even DD-WRT initial flashing is not available?

Kong's picture


did you add any access restrictions? Once you use those the speed will drop a lot since the filter for that needs to completely check all incoming traffic.

Netgear is only able to route at that speed because it uses fast_nat, which limits your feature set. Fully routing and firewalling a 300Mbps connection needs at least a machine with ~1Ghz unless routing is done in hardware which is not the case with these consumer routers.


I'm not going to add support for it, because I don't have a router to test with and even if I would think on buying one I would first have to find a seller that knows if he is selling V1 or V2:-)

It is really getting confusing lately since same models have sometimes completely different hardware e.g. WNDR3700 has Atheros and Broadcom SOCs.

I have already told zoomlink, that I'll probably stop releasing any public builds for broadcom units. Broadcom sucks because:

- you cannot upgrade the kernel ( add features introduced with new kernels )
- you cannot fix any bugs in the closed source wireless driver
- I cannot forward bugs to broadcom

mac913's picture


Kong said: ... I have already told zoomlink, that I'll probably stop releasing any public builds for broadcom units....


Hi Kong, I am very new using your builds but the features and support that you have given is outstanding. Everyone has to remember that Kong provides DD-WRT modded builds and all major issues should be forwarded to DD-WRT. Kong can fix minor isuues with DD-WRT for example SSH is broken with DD-WRT and working with KONG-MOD, this is one feature I need working for remote access.

I read that you where trying to get wireless drivers from Builds 15XXX into new the latest builds. I'm guessing you have hit a wall with this avenue. We are not expecting you to do the impossiable, you have done great job with your builds and I currently use your builds for all router gateways in my home and other family networks. With your latest build release 18010 the wireless has been the best so far for newer builds, the only issues I have run into have been with QoS Uplink Throttling doesn't throttle. I have read that there have been some DD-WRT fixes with QoS and any of your newer releaseswill reflect these fixes.

Thank-you for your builds and I hope you don't stop releasing KONG MOD Builds for Broadcom to us, as I prefer your newer builds over DD-WRT and I have been a long time user of DD-WRT almost 4-years and I have over a dozen Broadcom routers. Just so you know the last working build that I use from DD-WRT is Build 15962 (over a year old) and anything above that build is your build. I have 5 Boardcom routers running in my home using these flavors E3000, E2000, WRT610v1 & 2xWRT320 and I don't plan to move away from DD-WRT Broadcom routers anytime soon. So in I my case I hope you sick around as K26 builds are still a long way from being as good as K24 builds.

Thanks KONG for all your hard work, I appreciate it and I wish you the very best in the New Year!

drakko's picture
Kong said:....even if I would

Kong said:....even if I would think on buying one I would first have to find a seller that knows if he is selling V1 or V2:-)  

In Poland i know some stores that have v2 100% - they use model id: WNRL3500l-100PES. And at beginning of this week they also add comment that is V2 version. 

Kong's picture


I just had some time to look at it. QOS got broken with the latest changes in dd-wrt. I'll see when I have the time to fix it.

weaslasf's picture


i have a netgear wnr3500v2/U/L router and i'm using DD-WRT v24-sp2 (11/28/11) stdkong - build 17940M Firmware (maybe i will change to the actual one) and i tryed to use the minidlna server.

my samsung tv finds the dlna server but i can't see my files

my hdd has the following structur


in test folder is only one pic

my final goal is that the folders fotos, filme, musik are available in the dlna server.

could you please help me doing the configuration 

usb configurationnas configuration

Kong's picture
weaslasf's picture
i do. but it wont work.

i do. but it wont work.

first problem of this guide is that i dont have an UUID at my hdd. so i cant mount /jffs /opt /mnt and i have to use the automount.

so i try to use /mnt/disc0-part1/Test and add this at the foto section. but it dont works.

Kong's picture


weaslasf said: i do. but it wont work. first problem of this guide is that i dont have an UUID at my hdd. so i cant mount /jffs /opt /mnt and i have to use the automount. so i try to use /mnt/disc0-part1/Test and add this at the foto section. but it dont works.






is not the same as in your samba setup (which contains all mounted partitions in ints selection drop down)




And I'm pretty sure, that your partition was not mounted to /mnt/disc0-part1.

weaslasf's picture
i think i also tried to use

i think i also tried to use /tmp/mnt/disc0-part1/Test

So you think it should work if i use this path?
or at the end:

if it would not work, could you tell me how to mount my hdd to /jffs, so i can use the guide? as you can see on my screenshot, there is no uuid.

cleatus's picture
when trying to use opkg: has

when trying to use opkg: has no valid architecture, ignoring
for all packages. the architecture is correct.
any ideas?

Kong's picture


you are right, I shipped the wrong opkg from my source tree. Should be fixed in next build.

cleatus's picture
thanks for the response. is

thanks for the response. is there any way i can either get the version i have to work or replace the version i have with your new version?

or do you have any idea when your new build might be avail?

thanks a lot, your build looks like it's just what i needed for my rt-n16!

cleatus's picture
kong, please disregard my

kong, please disregard my previous questions.
how do you recommend to partition and mount for those using usb hdd storage. the dd-wrt owtrw says to disable jffs if using usb storage, but it appears ipkg and opkg are setup to use jffs. and what about swap partition, needed/possibly?

1) /opt /mnt /jffs swap
2) /opt /mnt /jffs noswap
3) /opt /mnt jffs enabled in ram noswap
4) /opt /mnt jffs in ram and swap

little confused about the best way to setup from scratch.

good luck with your build. do you have a donate page to keep these builds going strong? i had a hard time even finding your builds.

weaslasf's picture
what about my dlna issue? has

what about my dlna issue? has somebody an idea?

zoomlink's picture
weaslasf said: i think i also

weaslasf said: i think i also tried to use /tmp/mnt/disc0-part1/Test So you think it should work if i use this path? or at the end: /tmp/mnt/disc0-part1/Fotos /tmp/mnt/disc0-part1/Filme /tmp/mnt/disc0-part1/Musik if it would not work, could you tell me how to mount my hdd to /jffs, so i can use the guide? as you can see on my screenshot, there is no uuid.


Use the information from your USB Tab - Disk Info /tmp/mnt/disc0-part1and add your directory names ( /tmp/mnt/disc0-part1/Fotos) as you listed on your post.

Please let us know if it worked.

cleatus's picture
for some reason the firmware

for some reason the firmware won't apply/save wireless channel. is there a setting that would force this behavior? or perhaps it's an actual bug? just a heads up in case it is the latter.

emp's picture
hi, i got a wrt610n v2 r18010

hi, i got a wrt610n v2 r18010 with a mounted 1 TB drive (ext3),

the weird thing is that the filesize of newly uploaded files > 4 gb is displayed wrong, as if the transfer has been interupted, samba shows the correct value tough.

It is possible to read/streamcopy/transfer the whole file and download it again, files transfered prior the firmwareupdate are shown correctly and haven't been altered

 any input on "curing" this strange behaviour?

sdddwrt's picture
Hey, I have the problem

Hey, I have the problem explained on this post.

anyone have any ideas on what my problem could be?