tomato not installing

7 posts / 0 new
Last post
ka5j
ka5j's picture
tomato not installing

I'm attempting to install tomato_wgr614l.chk on a new WGR614L. Current hardware and firmware are:

Account Name     WGR614v8
Hardware Version     V8
Firmware Version     V1.1.2_1.0.23NA

I've read the other posts regarding installing/upgrading. I've tried tftp but it doesn't respond, and the green power LED never blinks on power up. My workstation running Windows is connected to the router via another switch per the article on problems with Windows interfaces taking longer than 3 seconds to enable, but I don't think tftp is ever active on the router.

I've tried connecting with ssh using Putty with user root@192.168.1.1 and admin@192.168.1.1, response: Network error: Connection refused. Searches in the forum indicate turning on SSH in the firmware but it must mean in dd-wrt or tomato already installed since I don't see this option in the netgear firmware.

What am I missing?

 

 

mona
mona's picture
To use SSH, you have to

To use SSH, you have to enable it first from gui. By default it is disable. So please check it.
If you do not have serial cable, you cant use tftp. Or you have to put mtd_erase in the board by using ssh, then board will be tftp enabled.
I think you have default Netgear version. You can upgrade firmware from gui. If you are using european version , use tomato_wgr614l-lzma.

SouvikGhosh
SouvikGhosh's picture
yes, ssh option is not there

yes, ssh option is not there in Netgear default firmware. But with the netgear firmware you should be able to install new firmware directly from the UI because this firmware accepts chk file for firmware upgrade. If you like to use tomato you can flush this image directly from the UI.
And yes, as mentioned by mona please be sure to use the lzma version (http://www.myopenrouter.com/download/10413/tomato_wgr614l-lzma/) if you are using the European version. Otherwise you can used the regular version.(http://www.myopenrouter.com/download/10285/Tomato-Firmware-for-WGR614L-v...)

ka5j
ka5j's picture
Thank you for your replies. I

Thank you for your replies. I downloaded the regular version of Tomato again (from your link, the non-European version) and tried to install but it gives me the same error, "Invalid filename was provided, please enter again." I tried upgrading the firmware from 1.1.2 to 1.1.11 which did not help either. Since I'm browsing to the .chk file I'm sure the filename is correct.

jtinney
jtinney's picture
ka5j, I had the same problem.

ka5j, I had the same problem. If you are trying to upgrade your firmware using Firefox 3, please try Internet Explorer or Firefox 2. I fought forever with this before contacting NETGEAR support and they confirmed that upgrading using Firefox 3 is not reliable because of this error. I'm interested to know if this is what you are experiencing. Best of luck.

ka5j
ka5j's picture
jtinney, thank you for your

jtinney, thank you for your reply. As soon as you said that my palm slapped my forehead. I forgot to try another browser. IE upgraded it fine. Interestingly, once it was upgraded, IE6 loads a blank page, where Firefox 3 loads the Tomato page.

Thank you for the info.

Xyzzy
Xyzzy's picture
I had the same problem.

I had the same problem. Using IE fixed it. Thanks for the info!