Tomato on RT-AC66U 80MHz @ 5GHz issue with builds 120/121

3 posts / 0 new
Last post
TimF's picture
Tomato on RT-AC66U 80MHz @ 5GHz issue with builds 120/121

I have run into an issue with Shibby's Tomato builds 120 and 121, both VPN and AIO. For 5GHz I can only choose 20 MHz or 40 MHz. There is no option for 80 MHz.


Hardware: ASUS RT-AC66U

After flashing and NVRAM wipe and a 2nd reboot before changing any settings. 5GHz network shows up as available.

Basic > Network > 5 GHz > Channel Width only has 20 MHz and 40 MHz options available.

Also channel width and channel selection seem to be messed up for both 5GHz and 2.4GHz.

For example: If I choose 20 MHz Channel Width and Channel 6 for 2.4GHz, the overview page still show it is using 40 MHz and Channel 1. Similar issue for 5GHz. It seems to confuse itself which channel is selected and what channel width.


I have tested builds 116 to 119 and they all have 80 MHz option available for 5GHz and channel selection for 5 and 2.4 GHz work as expected. I have gone back to build 119 for now. Perhaps it is just a bug introduced in the Web UI?

kevocl's picture
I've experienced the exact

I've experienced the exact same thing with build 121. I got a new router and it was compatible with Tomato USB (Shibby) so I thought I'd give it try. Obviously I downloaded the latest version, but was disappointed to see that 80MHz wasn't an option. I tried build 119 and 80MHz is available.

Wonder if 122 is affected the same way? There isn't 122 build for my router yet.

justyourimage's picture
From the Changelogs:

From the Changelogs:

16-10-2014 - 123 FIX2

- fix AC mode (80MHz channel width)