Will dd-wrt solve my weird R7000 ftp problem?

4 posts / 0 new
Last post
n6ac
n6ac's picture
Will dd-wrt solve my weird R7000 ftp problem?

We use a r7000 with factory firmware. Several D-link IP cameras are set to ftp images to a 1and1 server. Most, based on motion; some, on a regular interval basis. Weird behaviors for the last six months have included total stoppage of ftp access to the 1and1 server - often at a similar early-morning time, weekdays but not weekends. The only thing in my system that might be so time-aware seems to be the router (computer is not in the ftp path). When the stoppage occurs, can't even access the server from the computer. Another camera sends ftp to a second 1and1 server, different account, and never seems to have this problem.

I'm wondering if dd-wrt might potentially bypass this problem. Any thoughts out there?

Oh, and both 1and1 and my ISP claim it's not them.

n6ac
n6ac's picture
Oh, and power cycling or

Oh, and power cycling or otherwise resetting the router usually brings the ftp connections back to life.

But a power timer set for mid-early morning doesn't always get the job done.

sanju_cy
sanju_cy's picture
Enable USB support from

Enable USB support from Services -> USB -> Enable all USB support radio boxes.
Enable  JFFS support from Administration -> Management -> enable JFFS.
Navigate :Services->NAS. Enable ProFTPD and click on Apply Settings button.
Plug a usb drive on router which has single partition (say ntfs) OR Plug a usb drive on router which has multiple partitions (say ext2, ext3, vfat & ntfs) and all the partitions should be having some valid contents (say txt, image, doc, xls etc files).

Adding Share by clicking on Add Share button, select the proper path where the USB drive is properly mounted (say as /mnt/sda1), enter a Share Name (say Test_Share_1), select the public check box, select Read/Write for Access and click on Save button.

Adding User by clicking on Add User button, enter an User Name (say user1), enter Password (say admin), select Access Share check box (all added Shares are automatically displayed here), select the FTP/Samba service for this user and click on Save button.

Finally click on Apply Settings button.

From LAN machine's run the following command
#ftp 192.168.1.1
Provide user-name: user1
Password: admin
Now enter this binary command
# binary
Next to put a file form your local machine to the board usb drive, run the following commands.
ftp>put <local file name> ftp>put rlease.txt
OR
ftp> mput <local file extension> ftp>mput *.txt

Hope this will solve your problem.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Regards.

Sanju.

n6ac
n6ac's picture
Thanks, but I'm not wanting

Thanks, but I'm not wanting to store images on a local device - I want to use a remote server. 

The problem is that ftp communication to that server periodically becomes blocked, until the Netgear router is reset.