Wireless channel Stuck on Auto

7 posts / 0 new
Last post
rsoares28
rsoares28's picture
Wireless channel Stuck on Auto

Hello,

I just got my r7000 yesterday and installed DD-WRT v24-sp2 (03/07/15) kongac - build 26450M

Ive asked this question on the ddwrt forums and received some help but still can't choose a wireless channel for 5ghz.  2.4 is working fine.

Here are my settings

Wireless mode: AP

Network mode AC/N Mixed

If i choose 20mhz for width, i am allowed to choose a channel, as soon as i choose wide HT40 or VHT, channel defaults to Auto.

Any advice?  running insidder shows my 5ghz antenna on ch 36... my iphone 6 can only get up to 50 down when running a speed test.  Wired i get 140down.

The r7000 is replacing a linksys e4200.... i had that router setup on ch 153 and my iphone 6 would get speeds in the high 80's early 90's.... and thats only wifi n.

Thanks for any advice

bill1228
bill1228's picture
According to Kong over at DD

According to Kong over at DD-WRT you need to set each value individually starting at the top. After a change save and apply then do the next. Says that setting depend on the other settings and doing it this way things do not get confused. I have done it this way and everything can be defined as I want. I have seen the channel change to auto when I am doing the config but doing as suggested can set channel with no problem.

Also here is a link to Kong's info on wireless setup.

http://tips.desipro.de/2014/02/12/wireless-starters-guide-for-first-time...

Be sure and read through carefully before doing anything. I would suggest that you reset/clear nvram and start over with the settings following the guide.

--bill

rsoares28
rsoares28's picture
Thanks for the reply. A

Thanks for the reply. A reset is what i was looking to avoid. I spent some time copying over all my settings eg: port fwds, static ips from the e4200 and i'm dreading doing that again. What i'm hoping for is to firmware update to a new another firmware (keep all settings intact) in hopes its not that sensitive during the 5ghz setup.

How about moving to a brainsalyer build? Can i just go from Kong to BS and keep all my settings?

Thanks

bill1228
bill1228's picture
Yes you can go to a

Yes you can go to a brainslayer build from Kong as long as they are after 26138. That is where some network driver changes were made that required you to reset. You should be ok. Since Kong's fixes are rolled into the DD-WRT firmware you get his fixes using either.
Just a FYI, they are fighting through a bridging and guestnet issue right now on these builds. I don't use either. You read about more on the DD-WRT forums.

--bill

rsoares28
rsoares28's picture
Thanks for the reply. I

Thanks for the reply. I think i'm just going to go back to stock until they fully work out the kinks.

Does the stock firmware have the static routing option? like under ddwrt, Setup, advanced routing?

bill1228
bill1228's picture
TBH I do not know. I do not

TBH I do not know. I do not do any static routing so have not looked at it on OEM. I would assume yes, but do not know. Understand your going back, as things are in a state of flux right now. Doesn't bother me as I only do the basics plus DLNA so everything just works for me. I do not have any problems setting channels.

Sorry

--bill

antonioalves1706
antonioalves1706's picture
Had the same problem. After 2

Had the same problem. After 2 hours I decided to do 30-30-30 reset and start from scratch, changing and applying the settings one by one. It Worked!! :D

Bottom line: I figure out that the only thing preventing me from selecting channels were the Regulatory Domain, which was set to BRAZIL(where I live). With the reset I forgot to change it, leaving it as UNITED STATES, which allowed me to select the channels properly.

Antonio