R7000P 5GHz disappear when 2.4GHz using WPA2

3 posts / 0 new
Last post
ciscojunkie's picture
R7000P 5GHz disappear when 2.4GHz using WPA2

I have a R70000P running v3.0-r37015M kongac (09/23/18)

My 5GHz wireless suddenly disappeared (2.4GHz is working fine). I started searching around and found similar reports of this and found this old thread from 2014:


What happens now is the 5ghz band disappears. If I remove WPA2 from 5.0 it is still missing. When I disable WPA2 for the 2.4GHZ band, THEN both 2.4 and 5.0 appear again. 

I tried the same workaround (disabling WPA2 on 2.4GHz) and the 5GHz shows up. However, the thread ended by stating that the problem went away after hardcoding the channel, which I have done and it has no impact.

Any idea if others are seeing this same behavior? If so, is there a fix?

eeeehaw's picture
I have noticed 5HGz band

I have noticed 5HGz band repeatedly dropping in and out, despite the 2.4GHz band seemingly on continuously.  I have my R7800 set up in Access Point mode, and have not tried to see if there's a difference if it were in Router mode (shouldn't, given that the WiFi radios are used in both modes).  It is annoying, as all devices (WIndows, Andoir, Linux) frequently get 'no internet access' error messages on browsers and 'cannot connect to volume' for NAS volume connections, just to have it restored moments later.  I'm looking for a root cause of that problem, so far no success.  Very strong signal -34dbm on average, WPA2-PSK, SSID not broadcast, tried with Access Control on and off (specified MAC list).

This is one of two reasons that has brought me to look at alternative R7800 firmware here.


mrbubble597's picture
Had the same problem.  Here's

Had the same problem.  Here's how I resolved.  Mine is now very stable.