(final?) Recommended firmware for R7500 (V1)

7 posts / 0 new
Last post
yeasis's picture
(final?) Recommended firmware for R7500 (V1)

My R7500 on stock firmware is just unusable.

  • I have to restart the router every once in a while because i get lagg spikes every few seconds after a few days.
  • Sometimes i can't connect to it's wifi untill i restart it.
  • Sometimes i can find my spotify connect enabled Denon receiver, but most of the times i can't (i have confirmed this is a router issue)


I will never think about buying a Netgear router again, but since the hardware is very good, i was wondering if flashing a custom firmware can extend it's lifetime.

I have found multiple firmwares to flash:

  • DD-WRT mod by Kong (2018)
  • Open-WRT (2018)
  • Modified stock firmware by Rikko (2017)

What firmware is the most stable? I also read that it break 5ghz wifi and though that would suck i would prefer using only a 2.4ghz router over a unstable dual router.

Thanks in advance!

pb1983's picture
I use Kong on a R7000P...

I use Kong on a R7000P....very stable for me and I have not had any problems with 5gh wireless at all

tomasiq's picture
I tried new Openwrt. Out of

I tried new Openwrt. Out of the box it does not have 5GHz radio. So I reverted back. 

As it goes for DDWRT from Kong... I was not able to install it, the router could not get an connection with computer. Constantly trying to reconnect. I tried to restart, no result. I reverted back by tftp. Tried to install the old version of ddwrt from couple years back-success- but when I tried to update again I was not able to connect. 

Anybody was able to put this firmware? What version do you use? Could you please share it?

arma's picture
I confirm an issue with kong

I confirm an issue with kong mod and R7500v1. Tried flashing R7500v1-factory-to-ddwrt.img through webif as indicated in the release notes (https://www.myopenrouter.com/download/dd-wrt-kong-mod-netgear-r7500v1-2018-10-28-bin) and my router is stuck in an endless loop at boot : - (


firefox7518's picture
I have the same issue.

I have the same issue. Endless boot loop :-( Solutions?

10109090's picture
I also the same, now my

I also the same, now my router dead, ANY HELP?


CristianB's picture
Router is not dead but you

Router is not dead but you need to reflash with official firmware using TFTP.