cant revert to stock r9000

11 posts / 0 new
Last post
scorpio1377's picture
cant revert to stock r9000

Hello i have issue with my wifi using ddwrt so i wanted to revert back to stock. I followed every guide i have googled and it always does the same thing. 


it counts down 296 sec

then it just sits there saying upgrading firmware 

at the bottom left it says 1 percent uploaded

and it just sits there for more then a hour.

i tried closing page and rebooting router as well it always goes back to ddwrt.


I tried lastest firmware, also tried the firmware in download section. 

I even tried tftp2 with never connect no matter what i do.


Any help would be appriciated, thanks

scorpio1377's picture
update: i tried another

update: i tried another browswer and after 15 sec it says upgrade sucessful and reboots router but its still ddwrt.....

jfosella's picture
Did you try a reset? 

Did you try a reset? 

JSmith856's picture
same. I can't get DD-WRT off

same. I can't get DD-WRT off of my X10 R9000 back to netgear genie crap.... it takes, the file, says, "successful" but then comes back to DD-WRT.. is there a certain thing I am doing wrong?? 

jfosella's picture
I've gone back and forth

I've gone back and forth twice. Both times I kept playing with the rest button. Finally after many tries it goes. I assume you already loaded

chalkin85's picture
Which browser did you use? Im

Which browser did you use? Im currently unable to upgrade ddwrt. Stuck at 1% if you use CLI it just kills your SSH connection

allensmith12's picture
I also don't know the exact

I also don't know the exact process of the reverting stock. Can anyone tell me the exact guidelines to go on with this process?

buyer's picture
i too had similar issue was

i too had similar issue was using wrong image , post firmware upgrade just reseting by pressing reset button help.

just ensure you are using correct image ,  ddwrt-to-netgear-R9000.bin is one that should be used and not ddwrt-netgear-R9000.bin


124's picture
Hi, I also want to revert

Hi, I also want to revert ddwrt to netgear, but where  ddwrt-to-netgear-fw-R9000.bin can be found to download. I have found DOWNLOADS but failed.


wazapar's picture
anyone know how to revert

anyone know how to revert back to Stock from Voxel Firmware?

Lomtevas's picture
Use a LAN cable between a

Use a LAN cable between a laptop and port 1 on the X-10
Set your laptop to use a static IP address:

    Click the Windows icon in the taskbar or press the Windows key on your keyboard. The Start menu displays.
    Type network connections.
    Click View network connections or press the Enter key.
    Right-click Ethernet and select Properties.
    Double-click Internet Protocol Version 4 (TCP/IPv4).
    Select Use the following IP address and enter the following values:
        IP address:
        Subnet mask:
        Default gateway:
For MacOS, go to settings/internet and make these changes there.
Download the latest Netgear firmware release from the netgear website. Make a note of the folder it downloads to (usually into downloads).

To put the R9000 into TFTP mode.
1. Power off the router
2.Hold down the reset button
3.Power on the router and keep holding down the reset button (the router now becomes and is connected to the laptop).
4.When the router first boots the power led flashes and the port 1 LED flashes. The port 1 LED’s slow white flashes will change to a faster white flash. Let it blink 3-4 times on the faster white flashes and let go of the reset button.
5.The router is now in TFTP mode and ready to accept any IMG file.
6.Go to terminal, input CD tftp, and input tftp put <firmware file name> with the actual firmware file name in place of <firmware file name>.

Caution: Do not press Enter until each of the following steps happens!

Unplug all other Ethernet connections from your router, leaving only your laptop connected.
Turn your router off for 10 seconds.
Turn your router back on.
Wait for the port 1 LED to start flashing.
Return to the terminal app and press Enter to execute the tftp command and initiate the firmware upload.
Note: If the TFTP command is not recognized by your computer, you might have to enable TFTP in Windows Optional Features. Macs have the tftp app installed.
The upload might take a few minutes.
If the firmware upload fails, repeat steps 7-10.
Wait about 4 minutes for the router to finish storing the firmware into its flash memory.
When finished, the Power LED turns solid white and the wireless LEDs light up.
Return your Ethernet network connection settings in Windows or MacOS to the previous settings.

Essentially, all guides online that discuss how to restore the original netgear firmware into an X-10 router are incorrect as to the orange LED in the power indicator and which port to connect the laptop to. The correct port is number 1, and not the WAN port. ALso, the flashing LED must be the number 1 port, and not the power light. Also, there is no need to download the tftp program because modern systems include it. All that one must do is to time their reset button so that port 1 flashes quickly to permit the input of the original firmware.

Get ready to be disappointed. The original firmware is very bad, and DD-WRT is only a very slight improvement. The router and its firmware is a sore disappointment and not worth anywhere near the money.