Slow WAN speed

6 posts / 0 new
Last post
jspace's picture
Slow WAN speed

I've installed on my Netgear R6400 the firmware "DD-WRT Kong Mod for NETGEAR R6400 2016-11-10" because there are some features that the stock firmware don't have.
From now I'll speak about wired connections only. I don't speak about wireless performance.
I have gigabit internet provider with 1 Gbps down / 200 Mbps up and I experienced with this DD-WRT firmware a slow WAN to LAN speed: maximum 310 Mbps speedtest download. I tried also to disable the firewall without improvements.
With Netgear stock firmware (v I can get download values between 900 and 910 Mbps: this result for me is acceptable. (Connecting the PC directly to the gateway of the internet provider, bypassing the R6400 router, I can get speedtest download values between 938 and 942 Mbps).

There is a version of DD-WRT able to handle the gigabit connection with Netgear R6400?


Haldi's picture
I have the same issue.

I have the same issue.

I have a 400mbits Cable connection and a TC7230 Modem, connected the R6400 into the WAN port and use Tomato Firmware.

Speedtest Limit is 280mbits avg and 300mbits peak.


Stock Firmware does work fine up to 400mbits.

JuniorSenior's picture
How do i know my R400 is

How do i know my R400 is version 1 or v2 for flashing it with tomato?

Haldi's picture
Solved my issue.

Solved my issue.

In Advanced Settings-> Miscellaneous there is an option called " by activating this WAN speed got to a solid 400mbps.

rhiltbrunn's picture
I read, an article by a

I read, an article by a gentleman who did comparative testing using dd-wrt, tomato, openwrt, etc and the stock firmware from several netgear routers. The wan to lan speed on all was cut almost in half when using the opensource firmware.

His final conclusion was, if you want raw speed use the stock firmware, for more functionality use one of the open source firmwares. (I know that's obvious)

It is really unfortunate, but it looks like it's the current state of things.

I will try to find the post and put it up here if I do.


muhsinfatih's picture
CTF only worked for me on the

CTF only worked for me on the 1.28 -- 137 version for netgear r6400 (v1) (full filename: tomato-R6400-ARM--137-AIO-128K.trx). I spent hours on the 140 version and noticed that all the posts saying that CTF works are old. Tried the 137 version and voila!! My first speed test got me 912 down / 38 up (38 up is because my plan caps upload to 40mpbs)